Klx300 help - Kawasaki Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-12-2017, 02:33 AM
Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 1
Default Klx300 help

Hey guys am in need of help, I bought a 1997 klx300 earlier this year in June and has been running great until now.

when I start up the bike it runs fine for about 30 seconds and then the bike starts to pull itself foward when in neutral? I have no clue what it could be. Also, the bike idles fine but will randomly die. If you need more info to troubleshoot just ask. Thanks in advance.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help starting a klx300 stuartshomepc KLX 250S 3 05-13-2011 06:25 PM
KLX300 Headlight/KLX300 Carb' on Ebay WestOzKLX KLX 250S 0 09-08-2008 03:14 PM
klx300 won't fire sparky98531 KLX300R 3 05-18-2007 03:29 PM
klx300 won't fire sparky98531 General Tech 5 03-23-2006 06:24 AM
will klx300 slipon work on 250s head pipe? klxstiffler KLX 250S 5 02-23-2006 01:13 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT. The time now is 07:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.