General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Electrical Issue PLEASE HELP!

  #1  
Old 07-04-2019, 07:34 PM
Junior Member
Thread Starter
Join Date: Jul 2019
Posts: 2
Default Electrical Issue PLEASE HELP!

I have a KLX250 and I was out in the mountains the other day, and I noticed that the speedometer and digital display were flickering.....I figured it was just a loose wire and I would fix it when I got home.....Rode for about another 10-15 minutes and then the bike just died. The whole electrical system is dead. I have 12v at the battery......but everything else is dead...

1) I checked the negative ground cable and its securely connected to the engine
2) I checked the terminals on the battery and wiggled them, there is ZERO corrosion and they are nice and tight
3) I checked the fuses under the seat, the two for the fan and the ignition and the 20 amp main fuse.....all are good.
4) I checked the relay and there is 12v to it, but nothing coming out the other side....im not sure if thats normal....

I am really stumped here, Im not an electrical genius, but I know basics. I dont havethe money, time or a truck to take it to a shop.....

Can someone suggest some other things I can check?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dezil
New Member Area
1
07-05-2019 01:49 PM
r8d8ter
KLX 250S
3
08-31-2011 03:07 AM
Havok_96_2008
General Tech
0
04-25-2011 10:20 PM
Nakataco
General Tech
0
02-18-2011 08:14 PM
robmac
General Tech
7
07-12-2007 07:33 PM


Thread Tools
Search this Thread
Quick Reply: Electrical Issue PLEASE HELP!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.