09 Brute Force 750 wont crank - Kawasaki Forums


Kawasaki Quad's & ATV's Quad (Leisure) & ATV (Working) talk within here.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-22-2018, 01:38 PM
Junior Member
Thread Starter
 
Join Date: Aug 2018
Posts: 2
Default 09 Brute Force 750 wont crank

I have a 2008 brute force 750i with fuel injection and it wont crank at all when i turn the key on the dashboard stuff comes on like the neutral light speedometer ect. When i push the ignition button it does nothing, the headlight switch doesnt work, and the fuel pump doesnt come on either i checked the fuses and they are fine. Battery brand new in april, pulled it out anyway and took it to oreillys for a charge and test and checked out operating to spec. I have 12.8 v source. I have continuity between brown and black at the connector at the steering column when I depress the start switch so I know my start switch and engine stop switch are contacting. I pulled the connector from the starter solenoid (what kawi calls a starter relay, and they designate the relays we know them as control relays, but we're going to refer to it as a solenoid) and key on measure 12.2 v when depressing the start switch, so best I can tell the solenoid is getting the command. I don't have any leads to power the control side of the solenoid and check continuity between the load posts of the solenoid, but I may have to devise something to make work. I don't have continuity between either load post or solenoid case, but I infer that to be a good thing as these are not case grounded. Where would you go next? So far as best I can tell, I've determined that the following are good with voltage at the command side of the solenoid..
Neutral Switch (backed up by the neutral light coming on at the multifunction meter)
Starter button
Engine stop switch
Ignition switch
Main fuse

Per Kawi manual that leaves
Starter
wiring
control relay

Thoughts?
Reply With Quote
  #2  
Old 08-22-2018, 05:56 PM
Junior Member
Thread Starter
 
Join Date: Aug 2018
Posts: 2
Default Fixed

Fixed it, corrosion at the double spade connector at the control side of the starter solenoid.
Reply With Quote
  #3  
Old 08-24-2018, 02:46 AM
Senior Member
1st Gear Member
 
Join Date: Jan 2018
Posts: 168
Default

About the only active discussions on this forum revolve around KLX 250S bikes. You may have better luck at this forum:

Kawasaki ATV and Mule - Kawasaki Motorcycle Forums

or this one is even more focused:

https://www.kawieriders.com/forum/
__________________
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
96 kawasaki jet ski 750 ? Will a small pin crank work in a big pin crank and cases ? scrtch111 Kawasaki Jet Ski's 0 05-04-2012 05:13 AM
750 brute force skid plates scrooge PRIVATE For Sale / Trade Classifieds 0 02-22-2007 05:38 PM
07 750 brute force scrooge Kawasaki Quad's & ATV's 2 02-04-2007 02:40 PM
service manual for 2006 Brute Force 750 knot2wise Kawasaki Quad's & ATV's 0 01-29-2007 09:49 PM
just bought brute force 750 sbowling79 Kawasaki Quad's & ATV's 10 12-19-2006 08:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT. The time now is 01:34 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.