Teryx acceleration problems - Kawasaki Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-08-2017, 04:30 PM
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 1
Default Teryx acceleration problems

I think this has been asked before but I have a 2011 or 2012 terxy that I bought new three years ago. It has been running fine until this month. It only has about 1000 miles on it. Runs great at idle and all speeds until warmed up (at about 10 minutes) and then won't go faster than about 20 mph and backfires loudly if you try to make it go faster. Still idles smoothly and runs smooth until you try to make it go faster than 20. It is as if there is a governor on it or maybe a transfer of the electronic choke?? to a choke off mode??? I am just guessing here. My problem is it is in the jungles of southern Mexico and the dealer I bought it from doesn't have a clue. If it is beyond a spark plug these guys are idiots. Their answer to every engine problem is a new plug so they already put in new spark plugs.

Last edited by kenkarger; 03-08-2017 at 04:32 PM.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
14 Teryx or Teryx4 brandinrex Kawasaki Quad's & ATV's 0 04-15-2014 07:40 PM
'05 636 acceleration problems streetbikejunkie General Tech 8 10-20-2009 09:44 PM
Acceleration problems after mods kawicat KLX 250S 21 04-10-2007 06:03 AM
stx15f problems with top speed/acceleration coleman Kawasaki Jet Ski's 1 11-01-2006 11:05 PM
Hiccup on Acceleration Sid General Tech 2 07-06-2005 06:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT. The time now is 03:08 AM.