1992 Bayou 300 - Kawasaki Forums

Kawasaki Quad's & ATV's Quad (Leisure) & ATV (Working) talk within here.

1992 Bayou 300

  #1  
Old 07-10-2018, 04:57 PM
Junior Member
Thread Starter
Join Date: Nov 2017
Posts: 1
Default 1992 Bayou 300

When trying to turn over I was getting a clicking sound.
Replaced starter.
Now I'm not getting anything.
I have power at battery.
Connection at starter is good.
Green neutral light comes on, but no headlights etc.
Fuse is good.

What am I missing?

Thanks for any help.
 
  #2  
Old 07-12-2018, 12:58 AM
Senior Member
1st Gear Member
Join Date: Jan 2018
Posts: 208
Default

About the only active discussions on this forum revolve around KLX 250S bikes. You may have better luck at this forum:

Kawasaki ATV and Mule - Kawasaki Motorcycle Forums

or this one is even more focused:

https://www.kawieriders.com/forum/
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MMarty
Kawasaki Quad's & ATV's
0
04-06-2007 04:16 AM
MMarty
Kawasaki Quad's & ATV's
0
04-05-2007 03:53 AM
lg_rebel
Kawasaki Quad's & ATV's
0
12-25-2006 11:49 PM
acerulz
Kawasaki Quad's & ATV's
0
03-28-2006 04:57 AM
acerulz
General Tech
0
03-28-2006 04:56 AM


Thread Tools
Search this Thread
Quick Reply: 1992 Bayou 300


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.