tachometer stopped working on 04 klr 250 ? - Kawasaki Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-01-2008, 06:29 PM
Member
1st Gear Member
Thread Starter
 
Join Date: Mar 2008
Location:
Posts: 50
Default tachometer stopped working on 04 klr 250 ?

I was riding yesterday, looking right at my tach, and it went from 6g to 0 then started jumpimg all over the place. Now it kind of stays at 0 and every once in a while jumps around. Iv'e looked on the net and can't find any info. It's $200 to replace the tach, but how do I know if that's the problem. How does it get a signal from the engine?

I appreciate any knowledge on the subject. Can't look on the klr forum, well, I would say it's dead over there, but I don't think it was ever "alive".


Reply With Quote
  #2  
Old 06-01-2008, 08:06 PM
Senior Member
1st Gear Member
 
Join Date: Jun 2007
Location:
Posts: 724
Default RE: tachometer stopped working on 04 klr 250 ?

I have seen where a bad battery can cause problems with the Tach. I know that sounds weird but it happens. If you have a good test battery to try, do it. Clean the ground connections too. If the tach still doesn't work then it could be the Stator ot the tach itself. You may find used parts cheap on Ebay and then it's easy to diagnose. Good luck.
Reply With Quote
  #3  
Old 06-01-2008, 09:52 PM
Senior Member
1st Gear Member
 
Join Date: Dec 2005
Location:
Posts: 637
Default RE: tachometer stopped working on 04 klr 250 ?

I'm betting the speedo drive gear at the front hub has locked up and broke the drive tabs off. Tear off the front wheel and have a look. $50 item. Same part on the pre-'08 KLR. Just to make sure, take the cable off at the hub and attach a drill driver. slowly run the drill in one direction or the other. That will prove the speedo or drive failed. And I'm assuming you have already checked the cable.

Never mind...Tach. Got a little ahead of myself. Sorry
Reply With Quote
  #4  
Old 06-01-2008, 11:01 PM
Member
1st Gear Member
Thread Starter
 
Join Date: Mar 2008
Location:
Posts: 50
Default RE: tachometer stopped working on 04 klr 250 ?

Battery is good. I went out today to ride the bike and the tach worked for a few blocks and then quit again. So,is it possible the stator needs to be replaced? (if that's where the problem is)
Reply With Quote
  #5  
Old 06-01-2008, 11:12 PM
Senior Member
1st Gear Member
 
Join Date: Jun 2007
Location:
Posts: 724
Default RE: tachometer stopped working on 04 klr 250 ?

Quote:
ORIGINAL: klrjr

Battery is good. I went out today to ride the bike and the tach worked for a few blocks and then quit again. So,is it possible the stator needs to be replaced? (if that's where the problem is)
The fact that it works then stops leads me towards a loose wire or ground. Check the wiring first then it may be best to pop in a stator if it's not too expensive. If you have a multi-meter, you can isolat the wires and check for proper voltage(and ground) in the wires leading to the Tach. Once you get hooked to the correct wires, you can rev the engine and expect to see changes in the voltage as ypou rev the engine. That would prove the Tach to be faulty. If the voltages stay constant or open(broken wire/bad stator), the tach is good. This is my best guess at how to help you diagnose but there are some actual Motorcycle technicians on this forum that would know better. I believe djmerullo is a MC Technician. Good luck.
Reply With Quote
  #6  
Old 06-02-2008, 12:14 AM
Member
1st Gear Member
Thread Starter
 
Join Date: Mar 2008
Location:
Posts: 50
Default RE: tachometer stopped working on 04 klr 250 ?

I appreciate the insight. I understand the principle now, that helps alot!
Reply With Quote
  #7  
Old 06-02-2008, 07:24 AM
Senior Member
1st Gear Member
 
Join Date: Oct 2006
Location: Misawa Japan
Posts: 3,104
Default RE: tachometer stopped working on 04 klr 250 ?

I don't have a KLR250 schematic at my disposal, but usually the pulse signal coming from the statorusedfor RPM indication is the same one that is used to eventually generate an engine spark.

I'd almost put odds that if your engine is running OK, the stator is not your problem.

There is probably alooseor corroded connection somewhere....hopefullynot inside the actual gauge.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
kx 250 2000 stopped working! please help Mark Thompson KX250 & KX250F 0 07-13-2014 01:36 PM
Tachometer Odometers Not Working - 2009 Ninja 500 Thot General Tech 2 09-15-2012 04:33 PM
500 used ninja stopped working mookbooker Ninja 500R 5 04-14-2008 04:20 PM
Speedometer stopped working davehayward1 General Tech 3 03-16-2008 08:37 PM
HORN STOPPED WORKING dmar KLX 250S 11 05-29-2007 06:07 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT. The time now is 04:11 PM.