Go Back   Kawasaki Forums > Other Vehicles > Kawasaki Jet Ski's
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-26-2008, 11:13 PM
Junior Member
 
Join Date: May 2008
Posts: 1
Default zxi wont start

I HAVE A 96 ZXI900 , MY SON FLIPPED IT AT THE LAKE YESTERDAY , FILLED THE HULL W/ WATER, WE BROUGHT IT HOME , WONT START ONLY CLICKS . I PULLED THE CYLIDER HEAD OFF , WHEN I TRY AND START IT THE PISTONS MOVE SLIGHTLY SO I DONT THINK ITS FROZE UP, I PUT A BATTERY CHARGER ON IT BUT THE BATTERY NEVER FULLY CHARGES, TRYED TO JUMP IT WITH A CAR BUT NO LUCK. COULD IT BE THE STARTER, BATTERY OR POSSIBLY FROZEN CRANK? THEIR WAS WATER IN THE HULL FOR OABOUT 30 MINS TILL WE COULD GET IT DRAINED. I HAVE READ OTHER POSTS ABOUT HYDRO LOCK? BUT I WOULDNT THINK THE PISTONS WOULD BUDGE IF THAT WERE THE CASE. THANKS IN ADVANCE FOR ANY GUIDANCE YOU CAN GIVE.

Register now for free or log-in if already registered to remove this ad!
Reply With Quote
Old 05-26-2008, 11:13 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
-->

All times are GMT. The time now is 06:37 AM.

Internet Brands, Inc.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.